12/13/2022, 3:41 PM
been banging my head against a problem for a while and no luck. Was hoping someone more knowledgeable here has gone through the same issue and actually resolved it 😅 Now that i have my Netmaker server fully stable at home, i've decided to try it out for mobile VPN purposes. So i created a separate network with both ingress and egress defined and installed the wireguard client on my phone and laptop - so far so peachy, it works great. The trouble arises when i use those devices within my University network (both Wifi and LAN), in which case the wireguard tunnel can't connect to the peers. I've tried both with and without STUN, but no luck. I even tried a full node, instead of an external client and while it initially connects to retrive network info, further communications are blocked. I don't know what configurations the network admins implemented here, but in my quest to find out, i tried using a Tailscale node and it connected without a hitch. This leads me to believe that it is a problem of configurations on my side, as Taiscale also uses Wireguard under the hood. Any idea?