12/18/2021, 9:17 PM
The first thing to check is that ip forwarding is enabled on your ingress client,
sysctl net.ipv4.ip_forward
, (sometimes if mine is on and still not forwarding and I do a reboot, it will start working) So for egress, you you can accomplish that by referring to this thread: pretty much just use those as your gateway addresses and then set it to a internet accessible network interface on your node, like eth0 or whatever comes up when you
ip a
ip link show
. If you only want your ext clients to use it as a gateway then set your default ext client dns in the network settings to
or whatever dns you'd like and then you can just use as your gateway range, but your meshed nodes won't be able to access internet with that. Hope that helps