03/16/2022, 8:13 AM
Doh! Did a new fresh install of 0.12 hoping that I would manage to get it up and running this time, but I still fail. This time the linux node (pop-os) i'm trying to add just hangs at
[netclient] node created on remote server...updating configs
. The other node running Windows completes the join, but there is still no peer in the comms interface when running
wg show
, so the check-in isn't working. Is anybody else running the netmaker server on your LAN, or is everyone using a VPS? 😅 I'm running Netmaker in a Ubuntu 21.10 VM on my LAN. ufw is inactive (so I assume that nothing is blocked by ubuntu) and in my firewall/router (opnsense) I've forwarded ports 53 (no longer needed since 0.10??), 51821-51830 and 50051 to the Netmaker VM. 80/443 is handled by the nginx reverse proxy. I'm using the nm-quick.sh script( with the -d mydomain.com parameter) to get Netmaker up and running, and as I have nginx as reverse proxy I have modified the script to use docker-compose.nocaddy.yml instead. Have I missed some configuration that needs to be done in the Netmaker installation? Running out of ideas what to try next :/